Gleniffer Lake Rural Connect Internet Outage
Updates
Final update 23:36 MST Aug 30, 2026
Rural Connect services have been restored to Gleniffer Lake and Spruceview.
If your service is not working. Please try to reboot the router and fiber box.
We will keep this incident open for monitoring.
Current Outage Update: @ 18:40 MST
Next Outage Update: 06:30 MST Aug 31,2026
Rural Connect, who owns and operates the fiber network, has determined that the underlying cause of the current outage is a fiber optic cable cut. Please note that this incident is completely unrelated to the recent Tether migration.
While Edgar HighSpeed does not own or operate the physical fiber infrastructure, our team is dedicated to supporting you, answering your questions, and relaying all available information as quickly as possible.
At this time, we do not have a confirmed ETA for full restoration. However, due to the complex nature of fiber optic cable repairs, work is expected to take approximately 14–16 hours.
Phone agents and office staff do not have any more updated information than below. Please consider the below links as the latest and most up to date information.
Where to Track Live Updates:
For real-time progress and future outage notifications, please visit:
http://rc.edgarhighspeed.com and select “status” or review the pop up a direct link to the status page is here: https://status.edgarhighspeed.com
Thank you again for your continued patience and for being a valued customer.
Edgar HighSpeed Support Team
We were just updated from Rural Connect that the outage in Gleniffer Lake and Spruceview was caused by a fiber optic cable being cut.
At this time we do not have an ETA for repair.
We are relaying information as we get it and the most up to date information is here.
We understand how frustrating and disruptive service outages can be and will do our best to keep you updated.
Update from Rural Connect,
Rural Connect has confirmed that they are experiencing an outage in Spruceview and Gleniffer Lake. Physical Issue and Technicians have been dispatched.
Next Update 5:30 pm.
Resolved,
Currently seeing an issue at Gleniffer Lake with No Internet.
We have reached out to Rural Connect for details.
Next update at 3:30 pm today
← Back
Network Status