RCL NETWORK OUTAGE NOTICE

Major incident Rural Connect Fiber Internet
2026-06-02 12:10 MDT · 3 hours, 25 minutes

Updates

Resolved

3:35 pm All clients are back online.

June 2, 2026 · 15:35 MDT
Investigating

2:07 pm We are seeing the outage shrink to a handful of customers now but will continue to keep the incident open until fully closed.

June 2, 2026 · 14:07 MDT
Investigating

as of 1:02PM local time.

Outage has been upgraded to Major incident, no updates from Rural Connect however we are seeing large numbers of clients offline.

June 2, 2026 · 13:01 MDT
Investigating

Rural Connect is currently having intermittent issues network wide. They are aware and investigating.

Next update: 1:15 pm.

June 2, 2026 · 12:10 MDT

← Back