RCL NETWORK OUTAGE NOTICE

Major incident Rural Connect Fiber Internet
2026-01-19 09:41 MST · 22 hours, 41 minutes

Updates

Resolved

a hardware change was performed last night from Rural Connect and the issue has been resolved.

January 20, 2026 · 08:22 MST
Investigating

Rural Connect has Emergency Maintenance is scheduled for 11:00 pm tonight to 1:00 am tomorrow morning to provide a fix for the issues with flapping and intermittent connectivity.

Future updates will be provided tomorrow AM

January 19, 2026 · 14:16 MST
Update

Rural Connect has identified the issue and will be implementing a fix this evening. There will be an outage tonight and we will update this once more information is given.

January 19, 2026 · 13:06 MST
Issue

Rural Connect would like to inform you that we have observed interface flapping on one of our router interfaces. Our team is aware of the issue and has engaged our third-party service provider to conduct a detailed investigation.

No ETA for repair at this time.

January 19, 2026 · 09:41 MST

← Back