Rural Connect outage/slow
Major incident
Rural Connect Fiber Internet
2025-11-30 10:09 MST
· 2 hours, 41 minutes
Updates
Resolved
November 30, 2025 · 12:46 MST
Rural Connect has informed us that the issues have been resolved and all internet should be working as normal.
We are following up with them and expect an email with description of what happened in the next few days.
Investigating
November 30, 2025 · 12:13 MST
Some clients are back online, waiting for the official word from Rural Connect. 1:30 pm is eta for next update.
Investigating
November 30, 2025 · 11:28 MST
Update from Rural Connect they are investigating the issue.
Next update ETA 1:00pm
Issue
November 30, 2025 · 10:09 MST
Rural Connect is having an outage/slow issue after an update last night. Multiple reported issues and Rural Connect has been notified.
← Back
Network Status